预算编制系统

这个系统，是在《信息系统平台》下开发完成，从2004年初次编写以来，逐步进行功能扩展，至2.0，功能已经基本完善。强大而灵活的数据统计功能，是预算编制人员的好帮手，能使预算编制人员从预算编制的数据处理与统计的繁重工作中完全地解脱出来。

软件下载

信息系统平台： http://www.goldray.net/download/MISSetup.exe

预算编制模块： http://www.goldray.net/download/Budget.rar

文件说明

文件中 |  | 说明
MISSetup.exe |  | 信息系统平台安装程序，应当在每个终端安装，他是一个通用的数据库操作平台
Budget.rar | FiscalBudget.dll | 预算管理系统模块，必须安装到平台，详见“管理员”说明。
 | FiscalBudget.chm | 联机帮助，建议安装到平台，详见“管理员”说明。
 | FiscalBudget.mdb | 预算管理系统初始编码库，在使用导入编码时，应当是打开这个文件，详见后面“管理员”说明。

后台数据库

可选用 MSSQL、SYBASE 或 ORACLE 数据库系统。

如果采用 MSSQL 或 SYBASE 数据库，请在服务器新建一个数据库，如：budget

如果采用ORACLE 数据库，请在服务器上新建一个用户，并授于权限(至少要有建表的权限)。

客户端数据库配置

程序与配置 | MSSQL | SYBASE | ORACLE
安装客户端程序 | 不必要 | 不必要 | 必要
OLE DB | 不必要 | Sybase.ASEOLEDBProvider | OraOLEDB.Oracle
客户端连接配置 | 不必要 | 不必要 | 不必要

如果客户端操作系统是 Windows 98 / Windows 2000 Professional , 请安装 MDAC 2.8

关于更加详细的客户端配置，请参见《信息系统平台》的相关说明。

管理员

1、在管理员客户端安装《信息系统平台》V2.1 以上。

2、打开“操作员-连接到数据库”连接到后台数据库。

3、登录：用户名：Admin 口令：无

4、再打开“操作员-连接到数据库”，点击“存盘”，保存这个连接文件(如：conn.ini)。

5、将这个连接文件复制到内部WEB可下载的网站目录: 如：“http://xxx.xxx.xxx.xxx/”

6、在“维护-组织机构”中增加一个组织机构（帐套）。

7、在“维护-动态模块管理”中装载“预算编制模块”：在“信息系统平台”节点打开“FiscalBudget.dll”。

8、在“维护-动态模块管理”中装载“预算编制编码库”：在“信息系统平台”节点打开“FiscalBudget.chm”。

9、在“维护-动态模块管理”中维护“预算编制”的表：在“预算编制”节点点击工具条“表维护”。

10、导入编码库“财政供养方式”，“预算归口部门”，“预算科目”，“预算项目”，方法是：

打开编码表，点击工具条“打开”选择“FiscalBudget.mdb”即完成导入。导入前确保未录入任何编码数据。

11、编制“预算-编码-组织机构”表，为实现统计功能，请按部门分类结构进行分类。

操作员客户端

1、安装《信息系统平台》V2.1 以上。

2、打开“操作员-连接到数据库”，选择“数据库设备”为“数据库连接配置文件”, 在连接地址内录入连接文件的完整下载地址，如：“http://xxx.xxx.xxx.xxx/conn.ini”，点击“连接”。

3、登录。


财政供养方式

应用于一个预算单位的财政供养方式选项。

这个编码主要是用于数据统计，按序号即可。

快速导入编码

在无编码的情况下，可快速导入，请点击工具条“打开”，选择初始编码库 FiscalBudget.mdb 文件，点击“确定”即导入。


预算归口部门

应用于一个预算单位的属于那个财政科室管理。

是指财政内部管理预算单位的科室名称。

操作人员是指编辑人员，如果一个操作员未在这个部门的编辑人员名单中列出，那么他将不能编辑那些归口部门属于这个部门的预算单位的数据。操作员之间使用(半角)逗号分开。

一个操作员若要编辑一个预算归口部门所属单位的数据，除了在上述的操作人员名单内列出外，还应当在系统权限中有“编辑”权限，详见《信息系统平台》之“维护-操作员”。


组织机构

组织机构包括汇总单位与预算单位

组织机构应当是树状的列出，每级编码长度不限，级数不限，但由于代码总长度受限，关系是：

∑(每级编码长度 + 1) ≤ 32

选项 | 说明
汇总单位 | 这个单位是一个汇总单位，数据由其所属下属单位汇总而来，否则是一个预算单位
部门预算 | 这个单位是部门预算单位，未选中则是非部门预算
给养政策 | 见财政供养方式, 请点击选择
归口部门 | 见预算归口部门，请点击选择

为了方便地统计数据，建议按编制归口多级。

如果一个局还存在下级单位，那么，将这个局设为汇总单位，在其下级设一个“XX局机关”的预算单位，来核算这个局(不包括下级单位)的预算数据。

如果一个组织机构已经存在数据，那么，他将无法删除。


预算科目

请按财政部制定的预算科目编制，由于预算编制主要是支出类科目，因此，收入类科目不必录入。

顶级科目的“收入类科目”选项，“子项汇总”必须选中。

预算科目应当是树状的列出，级数不限(一般是“组”，“类”，“款”，“项”四级)，但由于代码长度受限，关系是：

∑(每级编码长度 + 1) ≤ 32

选项 |  | 说明
项目数据选项 | 子项汇总 | 这个科目的数据由其所属下列科目汇总而来
 | 其中数 | 这个科目的数据是其中数，不汇总到上级科目(不建议采用其中数)
收入类科目 |  | 必须为未选中，仅应用于顶级科目

在编制“财政预算拔款表”时，可选的预算科目必须是“子项汇总”未选中的科目。

在编制“财政预算拔款按科目汇总表”时，“子项汇总”选中的科目数据将从其下属子项汇总而来，因此，由于上下年度科目核算明细方式改变，有可能引起统计上年数据时，与当时的真实情况不符。但统计当年数据时，则无差错。

如果一个科目已经存在数据，那么，他将无法删除。


预算项目

预算项目包括汇总项目与具体项目

预算项目应当是树状的列出，级数不限，但由于代码长度受限，关系是：

∑(每级编码长度 + 1) ≤ 32

选项 |  | 说明
项目数据选项 | 子项汇总 | 这个项目的数据由其所属下列项目汇总而来
 | 其中数 | 这个项目的数据是其中数，不汇总到上级项目(不建议采用其中数)
该项目仅用于 | 部门 | 选中时当预算单位的"部门预算"选中，列出这个项目。
 | 非部门 | 选中时当预算单位的"部门预算"非选中时，列出这个项目。
应用于项目支出 |  | 这个项目的数据由"专项支出明细表"来编辑而来

“该项目仅用于”均未选中时，应用于所有单位。数据汇总表则不受此选项限制。

如果一个项目已经存在数据，那么，他将无法删除。


财政拨款预算表

这是一个数据编辑与查询统计通用的模块，当打开一个组织机构的数据时，若当前操作有编辑权限，那么将在编辑状态，否则在查询状态。

这个表的编辑操作权限与数据控制，请参见“维护－系统设置－预算编制设置”。

打开一个单位数据

点击工具条“打开”按钮，弹出打开对话框，请选择列表框内的单位，选定后点击“确定”将打开这个单位的数据。

如果是一个汇总单位，那么，展现在你面前的将是一个［核定数］统计表，将尽可能地列出最详细的数据，请检查“展开列至:”

预算科目：按预算单位、预算科目列出明细数据。

预算单位：按预算单位列出汇总数据。

下级：仅按下级组织机构列出汇总数据（孙级单位将汇总到汇总单位）。

注：虽然可能想要汇出更明细的数据，但由于列数最多只能是 64 列，超过这个列数，将自动转到可以展开到列以内的展开方式。

当选定的是一个预算单位，那么，打开的将是该预算单位的预算总表，请检查“打开数据:”

申请数：列出申请数。

核定数：列出核定数。

注：专项支出明细表不受这个列选项的限制，总是打开全部。

选择“预算科目”

点击工具条“科目”按钮，弹出“选择科目”对话框，请选中列表框内的预算科目(在科目前面的选项框内单击选中)，选中的将在右边的科目框内列出。

一个预算单位最多可用 64 个预算科目，如果超出这个限制，请将这个预算单位作为汇总单位，在下面设置下级单位来处理。

编辑数据

年度预算安排表

打开的必须是一个预算单位，才能根据权限来控制你是否对这个单位数据可编辑(详见：预算归口部门、预算编制 设置)。

单元格是否可编辑，将以颜色不同来区分。

在一个单元格内录入数据也

快速录入动作：录入一个数据后，按下行光标移至下一单元格。

说明栏仅对当前表有效。

每个单元格数据编辑后完成后（按回车、或焦点移至另一单元格），该表格相应的汇总数据也同时被刷新。假如一个项目单元格数据不能被统计，那么，这个项目编码可能是选中了“其中数”或其父级项目编码未选中“子项汇总”，与组织机构编码和预算科目编码无关。

专项支出明细表

如果当前打开的是汇总单位，将列出所属下级单位的全部专项支出明细表，并不可编辑。

如果当前打开的是一个预算单位，那么这是这个预算单位的专用项目支出明细表，并根据权限来控制你是否可编辑。

“序号”、“项目名称”必须录入，“预算项目”与“预算科目”同时也必须有所选择(增加记录时，将采用上条记录的值作为默认)，否则该数据将被视为无效的数据。“核定数”与“备注”可以不录入数据。

“申请数”与“核定数”录入后，将自动登记到“年度预算安排表”的相应项目行与科目列的单元格中，并汇总。

“项目名称”尽量简短，能说明问题即行，若要详细的项目说明，请编写到“备注”列内。

“项目名称”的内容，在编制汇总表时，将自动加上数据(万元)作为备注说明进行多项链接。

“序号”改变后，将重新排序。删除一行后，后续项目的序号将靠前。

数据保存

数据编辑后，必须点击工具条“存盘”才真正将数据保存到数据库中，存盘时将保存年度预算安排表与专项支出明细表的数据，保存时采用事务处理机制，如果保存不成功，将不会损坏原有数据。

专项支出明细表的申请数与核定数均为 0 的项目将不被保存。


财政拨款预算按科目汇总表

这是一个按预算科目的汇总表，你可以编制出详细的明细表。

打开数据

点击工具条“打开”按钮，弹出打开对话框，请选择汇总条件。

第一页：基本条件

第二页：预算项目

汇总表头明细列，最多可选128列

第三页：组织机构

第四页：组织性质

组织性质包括财政供养方式与归口部门，请参见“编码－组织机构”的编码库设置。

财政供养方式

选中了部分财政供养方式，将只汇总预算单位的财政供养方式相符的数据。而一个也没选中或选中全部，都将视为全部数据。

归口部门

选中了部分归口部门，将汇总预算单位的归口部门相符的数据。而一个也没选中或选中全部，都将视为全部数据。

展开标题

如下图，在左上角的“+”按钮上点击，回卷也同理。


财政拨款预算按单位汇总表

这是一个按组织机构的汇总表，你可以编制出详细的明细表。

打开数据

点击工具条“打开”按钮，弹出打开对话框，请选择汇总条件。

第一页：基本条件

第二页：预算项目

汇总表头明细列，最多可选128列

第三页：组织机构

第四页：组织性质

组织性质包括财政供养方式与归口部门，请参见“编码－组织机构”的编码库设置。

财政供养方式

选中了部分财政供养方式，将只汇总预算单位的财政供养方式相符的数据。而一个也没选中或选中全部，都将视为全部数据。

归口部门

选中了部分归口部门，将汇总预算单位的归口部门相符的数据。而一个也没选中或选中全部，都将视为全部数据。

展开标题

如下图，在左上角的“+”按钮上点击，回卷也同理。


预算编制设置

这个设置主要是应用于财政拔款预算表。

配置内容 | 说明
本年度无数据时，默认使用上年科目 | 可自动选择科目
申请数录入后转为核定数 | 一般是在基础数据刚开始录入时，转为核定数后，可减轻核定数录入工作量
核定数不能大于申请数 | 核定数总是不能大于申请数，否则请不要选中
当前编辑预算数据年度 | 必须与编辑年度一致，否则数据将不能编辑

注：这个功能仅适用于“系统管理员”


技术问题解答

有关技术问题，请联系：

电话：0578-8134092

邮箱：sczyq@163.com (请在邮件标题注明“预算编制”)