WEB 浏览器

《WEB 浏览器》模块为《信息系统平台》提供了 C/S 与 B/S 系统集成的解决方案。

这是个一站多页 WEB 浏览器，采用 IE 接口，可设置页面自动登录。

主要功能如下：

WEB 站点管理 | 系统管理员配置站点
设置 WEB 自动登录 | 操作员配置自动登录输入内容
浏览网页 | WEB 浏览器

使用方法：

1、进入“维护－WEB 站点管理”，配置站点与方式。

2、由操作员从“操作员－设置 WEB 自动登录”进行登录信息设置（无自动登录页面，此步可省）。

3、从“公共服务”菜单下，启动《WEB 浏览器》，浏览相关网站。


WEB 站点管理

该功能仅系统管理员可用！

在这是配置可浏览的 WEB 页面, 在根节点下编辑页面列表，如下图：

模块将根据这个站点列表生成系统菜单。

序号：

菜单排列次序。

名称：

是主键，一般指定后，若已经被引用，就不能再修改了，除非删除。

URL 地址：

是页面初始页，一般是以 http:// 开头，若是设置能够采用 GET 方式或 POST 方式自动登录的页面，应检查

若 URL 地址是“-”,生成一条菜单分栏线。

设置页面自动登录：

点击“WEB 站点管理”的下相应的子节点，进行登录配置，如下图：

这些数据来自该网站(https://reg.163.com/logins.jsp)的登录窗口的 HTML 源代码, 在分析代码后填入，如下图：

将网站登录 FORM 的 action 填入 URL 地址(注意要使用全称)

隐藏域(hidden)的名称与值均填入“公共变量”与“固定值”。

非隐藏域的名称与显示的标题填入“私有变量”与“控件说明”。

编辑完成后，重新登录后，在菜单的“公众服务”下增加 WEB 菜单，如下图：

可自动登录的的网站，每个操作员都应在菜单“操作员－设置 WEB 自动登录”中配置他的私有变量后，才能完成。


设置 WEB 自动登录

在这是配置可自动登录 WEB 页面的变量, 如下图：

提交值：即 WEB 登录页面的你应输入值，一般是用户名与口令。

这个数据仅对当前登录的操作员有效。


浏览网页

这是个一站多页 WEB 浏览器, 打开页面后，如下图：

同时，在菜单内生成工具条按钮如图　 [image] 。

点击窗口右上角的 [image] 关闭当前活动页面，当关闭最后一个页面时，同时关闭 WEB 浏览器窗口。